Authentication failure caused by pam software update on Ubuntu 8.10 Intrepid








After I run following command to upgrade the software:

sudo aptitude dist-upgrade

It installed/updated libpam-ck-connector software:

Setting up libpam-ck-connector (0.2.10-1ubuntu10) ...

pam-auth-update: Local modifications to /etc/pam.d/common-*, not updating.
pam-auth-update: Run pam-auth-update --force to override.

I did not choose to override the pam configurations: common-*. Because I was worried about the configurations for ldap being overwritten. However, after the upgrade, the ldap users cannot log in anymore.

The fix is to run following command:

sudo pam-auth-update –-force

You may want to look at /etc/pam.d/common-* files. Since there format have been changed.




No comments:

Post a Comment