Fix saslauthd start error when upgraded Debian Linux to Lenny








When upgrading debian to Lenny (5.0), sasl is also upgraded. However, the saslauthd cannot start any more.

You will see these errors:

Short name (NAME) undefined in /etc/default/saslauthd, using default (warning).
Starting : defaultNo run directory defined for default, not starting failed!

To fix the first line warning, insert

  • NAME="saslauthd"

to the beginning of /etc/default/saslauthd file.

To fix the second line error, change OPTIONS to
  • OPTIONS="-c -r -m /var/run/saslauthd"
in /etc/default/saslauthd file.



No comments:

Post a Comment