Google Web Toolkit 1.6 on Linux (Ubuntu 8.0.4) failed to compile and run. How to work around?








I am trying GWT 1.6 for Linux on my Ubuntu 8.0.4. It was using SUN JDK 6. However, GWT failed to compile and run the application:

#
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x0625665c, pid=15353, tid=2418424720
#
# Java VM: Java HotSpot(TM) Server VM (10.0-b23 mixed mode linux-x86)
# Problematic frame:
# V [libjvm.so+0x25665c]
#
# An error report file with more information is saved as:
# /mnt/stor/development/workspace/ownproject/WebShopModule/war/hs_err_pid15353.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#


http://code.google.com/p/google-web-toolkit/issues/detail?id=3382



To work around this problem, I had to change to openjdk 6:


sudo aptitude install openjdk-6-jdk
sudo update-java-alternatives -s java-6-openjdk



In eclipse, Window -> Preferences -> Java -> Installed JREs -> add ..., then select /usr/lib/jvm/java-6-openjdk


No comments:

Post a Comment