Eclipse on Mac OS: Use specific Java VM instead of the platform default version








After apply Apple's Java Mac OS X 2012-006 Update, it remove java plugin for browsers therefore the java applet and webstart applications no longer work. I downloaded Java 7 from Oracle. However, I wants my Eclipse use Java 6: To specify the Java VM for eclipse, you can edit the file: /Applications/eclipse/Eclipse.app/Contents/Info.plist

<key>Eclipse</key>
    <array>
         <string>-vm</string><string>/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Commands/java</string>
    ... ... ... ... ...
    </array>




No comments:

Post a Comment