Google web toolkit plugin for Eclipse: Errors running builder 'Google WebApp Project Validator'








Getting this error: Errors running builder 'Google WebApp Project Validator' on project 'myproject'. when trying to build a project using ant from Eclipse. (I have a GWT project in my Eclipse workspace but the project I was trying to build has nothing to do with GWT.)

It is a bug from Google plugin for Eclipse. The work around is:
  1. In Eclipse, open "Preferences...", Select "Google", then "Web Toolkit"
  2. Select a valid GWT sdk then click "OK" button. It will rebuild your workspace and fix the error.
The bug exists in GWT 2.4.0 and 2.5.0.


No comments:

Post a Comment